Please donate to help keep the servers running!

Main Menu

Can't play tfc fps stuck under 15

Started by TwatWaffle, January 25, 2020, 05:43:42 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


SO I tried messing with my config and increasing my fps as it was stuck at 66 so I added a few commands like fps_max 300,fps_override 1,gl_vsync 0 ran great after I added them then the next day it locked at 15 fps. I talked to nuggs in game he gave me his config to try, same result. I uninstalled tfc and reinstalled still same problem. I have GeForce gtx 645 card and I even tried restoring the values in there still stuck at 15 fps. As a side note no other game seems to be having this problem. Any help or suggestions would be greatly appreciated.


Very strange! 

Can you see if you're CPU or GPU is maxed out using a program like MSI Afterburner or windows resource manager?  Also can you verify if other steam games or other non-steam games have this issue?

Make sure you are running on OpenGL and  temporarily reduce resolution to see if that has an effect. 

Might also see if a there was a recent update (driver or windows) that corresponds to your trouble; you could always to revert. 

Then verify you have the latest video card driver.  Even if you do, reinstall it using a clean install. 


This is 100% a graphic driver issue.. What OS are you running?

Try switching renderer to software then back to OpenGL, try -nofbo launch option. Try running tfc (hl.exe) under compatibility mode.


Thank you. Seems to have been a driver issue. I downloaded the latest driver and everything went back to the way it was. I have to tweek my configs now because like an asshole I didn't back anything up in my frantic overwriting of configs to try and fix the problem. One last issue I could use help with is configs. Everytime I change classes I have to pull down console and type exec autoexec.cfg and exec userconfig.cfg to get my configs to work, if I put it in the autoexec or userconfig it won't let the game load at all.